Platform Degraded Performance

Incident Report for WorkRamp

Resolved

This incident has now been resolved.
Posted Sep 03, 2025 - 10:27 PDT

Investigating

We are currently investigating reports of platform slowness and errors within the Employee and Customer Learning Cloud.
Posted Sep 03, 2025 - 09:26 PDT
This incident affected: Employee Learning Cloud and Customer Learning Cloud.