EU Reporting Errors

Incident Report for WorkRamp

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 08:51 PDT

Investigating

We are currently investigating an issue with errors when loading reports from the Report Builder. This is limited to customers in the EU.
Posted Aug 12, 2025 - 07:28 PDT
This incident affected: EU Application.