workramp.com site error

Incident Report for WorkRamp

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 14:05 PDT

Investigating

Our marketing host Kinsta is currently experiencing site issues which leads to an error page on workramp.com. All WorkRamp services are currently functional and you can find the login page at app.workramp.com/login or through your company domain.
Posted Jun 12, 2025 - 11:35 PDT
This incident affected: Employee Learning Cloud.