Recurring slowness in application
Incident Report for WorkRamp
Resolved
Server responses should be back to normal now. Please email support@workramp.com if you have any other issues.
Posted May 17, 2019 - 15:36 PDT
Identified
We are seeing slowness in our application on certain requests. We are currently investigating
Posted May 17, 2019 - 15:06 PDT
This incident affected: Employee Learning Cloud.